using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(GRUB_CMDLINE_LINUX_DEFAULT=(?!.*elevator=noop).*)\""";
string input = @"GRUB_CMDLINE_LINUX_DEFAULT=""quiet""
GRUB_CMDLINE_LINUX_DEFAULT=""console=tty1 console=ttyS0""
GRUB_CMDLINE_LINUX_DEFAULT=""quiet elevator=noop""
GRUB_CMDLINE_LINUX_DEFAULT=""console=tty1 console=ttyS0 elevator=noop""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}