$re = '/^(GRUB_CMDLINE_LINUX_DEFAULT=(?!.*elevator=noop).*)\"/m';
$str = 'GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX_DEFAULT="console=tty1 console=ttyS0"
GRUB_CMDLINE_LINUX_DEFAULT="quiet elevator=noop"
GRUB_CMDLINE_LINUX_DEFAULT="console=tty1 console=ttyS0 elevator=noop"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);