#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(.*?\|[А-Я][а-я]{2,}\|[А-Я][а-я]{2,}\|))"
Local $sString = "email1@pochta.ru|Имя|Фамилия|2|1965-10-06|" & @CRLF & _
"email2@pochta.ru|дебильное имя|дебилЬная ФамилиZ|2|1976-04-03|Россия, Московская обл."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")