const regex = /^(?!(.*?\|[А-Я][а-я]{2,}\|[А-Я][а-я]{2,}\|))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(.*?\\|[А-Я][а-я]{2,}\\|[А-Я][а-я]{2,}\\|))', 'gm')
const str = `email1@pochta.ru|Имя|Фамилия|2|1965-10-06|
email2@pochta.ru|дебильное имя|дебилЬная ФамилиZ|2|1976-04-03|Россия, Московская обл.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}