import re
regex = re.compile(r"^(?!(.*?\|[А-Я][а-я]{2,}\|[А-Я][а-я]{2,}\|))", flags=re.MULTILINE)
test_str = ("email1@pochta.ru|Имя|Фамилия|2|1965-10-06|\n"
"email2@pochta.ru|дебильное имя|дебилЬная ФамилиZ|2|1976-04-03|Россия, Московская обл.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")