import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(.*?\\|[А-Я][а-я]{2,}\\|[А-Я][а-я]{2,}\\|))";
final String string = "email1@pochta.ru|Имя|Фамилия|2|1965-10-06|\n"
+ "email2@pochta.ru|дебильное имя|дебилЬная ФамилиZ|2|1976-04-03|Россия, Московская обл.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}