use strict;
my $str = 'email1@pochta.ru|Имя|Фамилия|2|1965-10-06|
email2@pochta.ru|дебильное имя|дебилЬная ФамилиZ|2|1976-04-03|Россия, Московская обл.';
my $regex = qr/^(?!(.*?\|[А-Я][а-я]{2,}\|[А-Я][а-я]{2,}\|))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}