#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<ip>(?:[0-9]{1,3}\.){3}[0-9]{1,3})[\s,]"
Local $sString = ""166.78.66.241" 70.121.107.109 "70.121.107.109" - - [19/Jan/2018:12:24:33 -0600] "POST /fileUpload/image HTTP/1.1" 200 - 137895 214 UCT-556540 "-" "-" "-"" & @CRLF & _
"" & @CRLF & _
" 10.210.192.15 - - [19/Jan/2018:11:00:22 -0500] "POST /fileUpload/image HTTP/1.1" 200 - "-" "-"" & @CRLF & _
" " & @CRLF & _
" 27.127.175.202, 192.168.10.101 - - [19/Jan/2018:08:59:53 +0900] "POST /fileUpload/image HTTP/1.1" 200 - "-" "-""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")