use strict;
my $str = '"166.78.66.241" 70.121.107.109 "70.121.107.109" - - [19/Jan/2018:12:24:33 -0600] "POST /fileUpload/image HTTP/1.1" 200 - 137895 214 UCT-556540 "-" "-" "-"
10.210.192.15 - - [19/Jan/2018:11:00:22 -0500] "POST /fileUpload/image HTTP/1.1" 200 - "-" "-"
27.127.175.202, 192.168.10.101 - - [19/Jan/2018:08:59:53 +0900] "POST /fileUpload/image HTTP/1.1" 200 - "-" "-"';
my $regex = qr/(?<ip>(?:[0-9]{1,3}\.){3}[0-9]{1,3})[\s,]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}