import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<ip>(?:[0-9]{1,3}\\.){3}[0-9]{1,3})[\\s,]";
final String string = "\"166.78.66.241\" 70.121.107.109 \"70.121.107.109\" - - [19/Jan/2018:12:24:33 -0600] \"POST /fileUpload/image HTTP/1.1\" 200 - 137895 214 UCT-556540 \"-\" \"-\" \"-\"\n\n"
+ " 10.210.192.15 - - [19/Jan/2018:11:00:22 -0500] \"POST /fileUpload/image HTTP/1.1\" 200 - \"-\" \"-\"\n"
+ " \n"
+ " 27.127.175.202, 192.168.10.101 - - [19/Jan/2018:08:59:53 +0900] \"POST /fileUpload/image HTTP/1.1\" 200 - \"-\" \"-\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}