# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<ip>(?:[0-9]{1,3}\.){3}[0-9]{1,3})[\s,]"
test_str = ("\"166.78.66.241\" 70.121.107.109 \"70.121.107.109\" - - [19/Jan/2018:12:24:33 -0600] \"POST /fileUpload/image HTTP/1.1\" 200 - 137895 214 UCT-556540 \"-\" \"-\" \"-\"\n\n"
" 10.210.192.15 - - [19/Jan/2018:11:00:22 -0500] \"POST /fileUpload/image HTTP/1.1\" 200 - \"-\" \"-\"\n"
" \n"
" 27.127.175.202, 192.168.10.101 - - [19/Jan/2018:08:59:53 +0900] \"POST /fileUpload/image HTTP/1.1\" 200 - \"-\" \"-\"")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.