// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?<ip>(?:[0-9]{1,3}\.){3}[0-9]{1,3})[\s,]").unwrap();
let string = "\"166.78.66.241\" 70.121.107.109 \"70.121.107.109\" - - [19/Jan/2018:12:24:33 -0600] \"POST /fileUpload/image HTTP/1.1\" 200 - 137895 214 UCT-556540 \"-\" \"-\" \"-\"
10.210.192.15 - - [19/Jan/2018:11:00:22 -0500] \"POST /fileUpload/image HTTP/1.1\" 200 - \"-\" \"-\"
27.127.175.202, 192.168.10.101 - - [19/Jan/2018:08:59:53 +0900] \"POST /fileUpload/image HTTP/1.1\" 200 - \"-\" \"-\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}