# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\s+|\s+$|\s*(,|:|\[|\]|{|})\s*/$1/gm;t' <<< "{
\"glossary\": {
\"title\": \"example glossary\",
\"GlossDiv\": {
\"title\": \"S\",
\"GlossList\": {
\"GlossEntry\": {
\"ID\": \"SGML\",
\"SortAs\": \"SGML\",
\"GlossTerm\": \"Standard Generalized Markup Language\",
\"Acronym\": \"SGML\",
\"Abbrev\": \"ISO 8879:1986\",
\"GlossDef\": {
\"para\": \"A meta-markup \s \dd language, used to create markup languages such as DocBook.\",
\"GlossSeeAlso\": [ \"GML\", \"XML\"]
},
\"GlossSee\" : \"markup\"
}
}
}
}
}"