import re
regex = re.compile(r"^\s+|\s+$|\s*(,|:|\[|\]|{|})\s*", flags=re.MULTILINE)
test_str = ("{\n"
" \"glossary\": {\n"
" \"title\": \"example glossary\",\n"
" \"GlossDiv\": {\n"
" \"title\": \"S\",\n"
" \"GlossList\": {\n"
" \"GlossEntry\": {\n"
" \"ID\": \"SGML\",\n"
" \"SortAs\": \"SGML\",\n"
" \"GlossTerm\": \"Standard Generalized Markup Language\",\n"
" \"Acronym\": \"SGML\",\n"
" \"Abbrev\": \"ISO 8879:1986\",\n"
" \"GlossDef\": {\n"
" \"para\": \"A meta-markup \\s \\dd language, used to create markup languages such as DocBook.\",\n"
" \"GlossSeeAlso\": [ \"GML\", \"XML\"]\n"
" },\n"
" \"GlossSee\" : \"markup\"\n"
" }\n"
" }\n"
" }\n"
" }\n"
"}")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)