package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s+|\s+$|\s*(,|:|\[|\]|{|})\s*`)
var str = `{
"glossary": {
"title": "example glossary",
"GlossDiv": {
"title": "S",
"GlossList": {
"GlossEntry": {
"ID": "SGML",
"SortAs": "SGML",
"GlossTerm": "Standard Generalized Markup Language",
"Acronym": "SGML",
"Abbrev": "ISO 8879:1986",
"GlossDef": {
"para": "A meta-markup \s \dd language, used to create markup languages such as DocBook.",
"GlossSeeAlso": [ "GML", "XML"]
},
"GlossSee" : "markup"
}
}
}
}
}`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}