const regex = /^\s+|\s+$|\s*(,|:|\[|\]|{|})\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s+|\\s+$|\\s*(,|:|\\[|\\]|{|})\\s*', 'gm')
const str = `{
"glossary": {
"title": "example glossary",
"GlossDiv": {
"title": "S",
"GlossList": {
"GlossEntry": {
"ID": "SGML",
"SortAs": "SGML",
"GlossTerm": "Standard Generalized Markup Language",
"Acronym": "SGML",
"Abbrev": "ISO 8879:1986",
"GlossDef": {
"para": "A meta-markup \\s \\dd language, used to create markup languages such as DocBook.",
"GlossSeeAlso": [ "GML", "XML"]
},
"GlossSee" : "markup"
}
}
}
}
}`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);