re = /^\s+|\s+$|\s*(,|:|\[|\]|{|})\s*/m
str = '{
"glossary": {
"title": "example glossary",
"GlossDiv": {
"title": "S",
"GlossList": {
"GlossEntry": {
"ID": "SGML",
"SortAs": "SGML",
"GlossTerm": "Standard Generalized Markup Language",
"Acronym": "SGML",
"Abbrev": "ISO 8879:1986",
"GlossDef": {
"para": "A meta-markup \\s \\dd language, used to create markup languages such as DocBook.",
"GlossSeeAlso": [ "GML", "XML"]
},
"GlossSee" : "markup"
}
}
}
}
}'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result