use strict;
my $str = '{
"glossary": {
"title": "example glossary",
"GlossDiv": {
"title": "S",
"GlossList": {
"GlossEntry": {
"ID": "SGML",
"SortAs": "SGML",
"GlossTerm": "Standard Generalized Markup Language",
"Acronym": "SGML",
"Abbrev": "ISO 8879:1986",
"GlossDef": {
"para": "A meta-markup \\s \\dd language, used to create markup languages such as DocBook.",
"GlossSeeAlso": [ "GML", "XML"]
},
"GlossSee" : "markup"
}
}
}
}
}';
my $regex = qr/^\s+|\s+$|\s*(,|:|\[|\]|{|})\s*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";