#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(Plugins(?!.*\bdns\b).*)$"
Local $sString = "Plugins = none, of,the, required_ones" & @CRLF & _
"Plugins=still,missing,here" & @CRLF & _
"Plugins = one,other,dns,else" & @CRLF & _
"Plugins= some,where,dns,in,there" & @CRLF & _
"Plugins=the,very,last,thing,dns"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")