$re = '/^(Plugins(?!.*\bdns\b).*)$/m';
$str = 'Plugins = none, of,the, required_ones
Plugins=still,missing,here
Plugins = one,other,dns,else
Plugins= some,where,dns,in,there
Plugins=the,very,last,thing,dns';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);