re = /^(Plugins(?!.*\bdns\b).*)$/m
str = 'Plugins = none, of,the, required_ones
Plugins=still,missing,here
Plugins = one,other,dns,else
Plugins= some,where,dns,in,there
Plugins=the,very,last,thing,dns'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end