import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(Plugins(?!.*\\bdns\\b).*)$";
final String string = "Plugins = none, of,the, required_ones\n"
+ "Plugins=still,missing,here\n"
+ "Plugins = one,other,dns,else\n"
+ "Plugins= some,where,dns,in,there\n"
+ "Plugins=the,very,last,thing,dns";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}