import re
regex = re.compile(r"^(Plugins(?!.*\bdns\b).*)$", flags=re.MULTILINE)
test_str = ("Plugins = none, of,the, required_ones\n"
"Plugins=still,missing,here\n"
"Plugins = one,other,dns,else\n"
"Plugins= some,where,dns,in,there\n"
"Plugins=the,very,last,thing,dns")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")