#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "entity(?![0-9a-zA-Z_-])"
Local $sString = "entity" & @CRLF & _
"entity," & @CRLF & _
"[entity]" & @CRLF & _
"entity-foo" & @CRLF & _
"entity_bar" & @CRLF & _
"entityfoobar" & @CRLF & _
"entity0foo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")