import re
regex = re.compile(r"entity(?![0-9a-zA-Z_-])")
test_str = ("entity\n"
"entity,\n"
"[entity]\n"
"entity-foo\n"
"entity_bar\n"
"entityfoobar\n"
"entity0foo")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")