re = /entity(?![0-9a-zA-Z_-])/
str = 'entity
entity,
[entity]
entity-foo
entity_bar
entityfoobar
entity0foo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end