$re = '/entity(?![0-9a-zA-Z_-])/';
$str = 'entity
entity,
[entity]
entity-foo
entity_bar
entityfoobar
entity0foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);