import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "entity(?![0-9a-zA-Z_-])";
final String string = "entity\n"
+ "entity,\n"
+ "[entity]\n"
+ "entity-foo\n"
+ "entity_bar\n"
+ "entityfoobar\n"
+ "entity0foo";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}