const regex = /entity(?![0-9a-zA-Z_-])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('entity(?![0-9a-zA-Z_-])', 'g')
const str = `entity
entity,
[entity]
entity-foo
entity_bar
entityfoobar
entity0foo`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}