#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[ \t]*("[^"]*")"
Local $sString = "[" & @CRLF & _
" {" & @CRLF & _
" "group": "Simple"," & @CRLF & _
" "name": "Simple"," & @CRLF & _
" "category name": "Apps"," & @CRLF & _
" "icon": "Simple.svg"," & @CRLF & _
" "paths": [" & @CRLF & _
" { " & @CRLF & _
" "path": "notepad.exe"" & @CRLF & _
" }" & @CRLF & _
" ]" & @CRLF & _
" }," & @CRLF & _
" // some comment here" & @CRLF & _
" {" & @CRLF & _
" "group": "Simple"," & @CRLF & _
" "name": "Simple"," & @CRLF & _
" "category name": "Simple"," & @CRLF & _
" "icon": "Simple.svg"" & @CRLF & _
" "paths": [" & @CRLF & _
" { " & @CRLF & _
" "path": "notepad"," & @CRLF & _
" "args": "notepad.py" " & @CRLF & _
" }," & @CRLF & _
" { " & @CRLF & _
" "path": "run.exe"," & @CRLF & _
" }" & @CRLF & _
" ]" & @CRLF & _
" }" & @CRLF & _
" ]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")