import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[ \\t]*(\"[^\"]*\")";
final String string = "[\n"
+ " {\n"
+ " \"group\": \"Simple\",\n"
+ " \"name\": \"Simple\",\n"
+ " \"category name\": \"Apps\",\n"
+ " \"icon\": \"Simple.svg\",\n"
+ " \"paths\": [\n"
+ " { \n"
+ " \"path\": \"notepad.exe\"\n"
+ " }\n"
+ " ]\n"
+ " },\n"
+ " // some comment here\n"
+ " {\n"
+ " \"group\": \"Simple\",\n"
+ " \"name\": \"Simple\",\n"
+ " \"category name\": \"Simple\",\n"
+ " \"icon\": \"Simple.svg\"\n"
+ " \"paths\": [\n"
+ " { \n"
+ " \"path\": \"notepad\",\n"
+ " \"args\": \"notepad.py\" \n"
+ " },\n"
+ " { \n"
+ " \"path\": \"run.exe\",\n"
+ " }\n"
+ " ]\n"
+ " }\n"
+ " ]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}