re = /^[ \t]*("[^"]*")/m
str = '[
{
"group": "Simple",
"name": "Simple",
"category name": "Apps",
"icon": "Simple.svg",
"paths": [
{
"path": "notepad.exe"
}
]
},
// some comment here
{
"group": "Simple",
"name": "Simple",
"category name": "Simple",
"icon": "Simple.svg"
"paths": [
{
"path": "notepad",
"args": "notepad.py"
},
{
"path": "run.exe",
}
]
}
]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end