using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[ \t]*(""[^""]*"")";
string input = @"[
{
""group"": ""Simple"",
""name"": ""Simple"",
""category name"": ""Apps"",
""icon"": ""Simple.svg"",
""paths"": [
{
""path"": ""notepad.exe""
}
]
},
// some comment here
{
""group"": ""Simple"",
""name"": ""Simple"",
""category name"": ""Simple"",
""icon"": ""Simple.svg""
""paths"": [
{
""path"": ""notepad"",
""args"": ""notepad.py""
},
{
""path"": ""run.exe"",
}
]
}
]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}