import re
regex = re.compile(r'^[ \t]*("[^"]*")', flags=re.MULTILINE)
test_str = ("[\n"
" {\n"
" \"group\": \"Simple\",\n"
" \"name\": \"Simple\",\n"
" \"category name\": \"Apps\",\n"
" \"icon\": \"Simple.svg\",\n"
" \"paths\": [\n"
" { \n"
" \"path\": \"notepad.exe\"\n"
" }\n"
" ]\n"
" },\n"
" // some comment here\n"
" {\n"
" \"group\": \"Simple\",\n"
" \"name\": \"Simple\",\n"
" \"category name\": \"Simple\",\n"
" \"icon\": \"Simple.svg\"\n"
" \"paths\": [\n"
" { \n"
" \"path\": \"notepad\",\n"
" \"args\": \"notepad.py\" \n"
" },\n"
" { \n"
" \"path\": \"run.exe\",\n"
" }\n"
" ]\n"
" }\n"
" ]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")