# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\G[^ :]*\K /\\ /gm;t' <<< "NetworkManager/system connections/Wired 1.nmconnection:14 address1=10.1.10.71/24,10.1.10.1"