const regex = /\G[^ :]*\K /gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\G[^ :]*\\K ', 'gm')
const str = `NetworkManager/system connections/Wired 1.nmconnection:14 address1=10.1.10.71/24,10.1.10.1`;
const subst = `\\ `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);