import re
regex = re.compile(r"\G[^ :]*\K ", flags=re.MULTILINE)
test_str = "NetworkManager/system connections/Wired 1.nmconnection:14 address1=10.1.10.71/24,10.1.10.1"
subst = "\\\\ "
result = regex.sub(subst, test_str)
if result:
print(result)