#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^(DHL)((?!@dhl\.com).)*$)|(^(SF\sEXPRESS)((?!@sf-express\.com).)*$)"
Local $sString = "DHL EXPRESS <notice@otherdomain.com>" & @CRLF & _
"DHL EXPRESS <notice@dhl.com>" & @CRLF & _
"" & @CRLF & _
"SF EXPRESS <notice@spamdomain.com>" & @CRLF & _
"SF EXPRESS <notice@sf-express.com>" & @CRLF & _
"" & @CRLF & _
"Any Email Address <any@emailaddress.com>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")