import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(DHL)((?!@dhl\\.com).)*$)|(^(SF\\sEXPRESS)((?!@sf-express\\.com).)*$)";
final String string = "DHL EXPRESS <notice@otherdomain.com>\n"
+ "DHL EXPRESS <notice@dhl.com>\n\n"
+ "SF EXPRESS <notice@spamdomain.com>\n"
+ "SF EXPRESS <notice@sf-express.com>\n\n"
+ "Any Email Address <any@emailaddress.com>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}