re = /(^(DHL)((?!@dhl\.com).)*$)|(^(SF\sEXPRESS)((?!@sf-express\.com).)*$)/m
str = 'DHL EXPRESS <notice@otherdomain.com>
DHL EXPRESS <notice@dhl.com>
SF EXPRESS <notice@spamdomain.com>
SF EXPRESS <notice@sf-express.com>
Any Email Address <any@emailaddress.com>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end