const regex = /(^(DHL)((?!@dhl\.com).)*$)|(^(SF\sEXPRESS)((?!@sf-express\.com).)*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^(DHL)((?!@dhl\\.com).)*$)|(^(SF\\sEXPRESS)((?!@sf-express\\.com).)*$)', 'gm')
const str = `DHL EXPRESS <notice@otherdomain.com>
DHL EXPRESS <notice@dhl.com>
SF EXPRESS <notice@spamdomain.com>
SF EXPRESS <notice@sf-express.com>
Any Email Address <any@emailaddress.com>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}