import Foundation
let pattern = #"(^(DHL)((?!@dhl\.com).)*$)|(^(SF\sEXPRESS)((?!@sf-express\.com).)*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
DHL EXPRESS <notice@otherdomain.com>
DHL EXPRESS <notice@dhl.com>
SF EXPRESS <notice@spamdomain.com>
SF EXPRESS <notice@sf-express.com>
Any Email Address <any@emailaddress.com>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)