use strict;
my $str = '<a href="word-word-word.html">';
my $regex = qr/<a href="(?!:images\/|\.\.\/|#|http:\/\/)(.*?)\.html">/mp;
my $subst = '<a href="prefix-$1.html">';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";