$re = '/<a href="(?!:images\/|\.\.\/|#|http:\/\/)(.*?)\.html">/m';
$str = '<a href="word-word-word.html">';
$subst = "<a href=\"prefix-$1.html\">";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;