import re
regex = re.compile(r"<a href=\"(?!:images\/|\.\.\/|#|http:\/\/)(.*?)\.html\">", flags=re.MULTILINE)
test_str = "<a href=\"word-word-word.html\">"
subst = "<a href=\"prefix-$1.html\">"
result = regex.sub(subst, test_str)
if result:
print(result)