# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([tk]) . b/\1 . p/gm;t' <<< "? ' a l t . b aU
m u . z ' i: k . b r a n . C @
r ' Y k . b @ . ts y: . k l I C"