import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([tk]) . b";
final String string = "? ' a l t . b aU\n"
+ "m u . z ' i: k . b r a n . C @\n"
+ "r ' Y k . b @ . ts y: . k l I C";
final String subst = "\\1 . p";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}