// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([tk]) . b").unwrap();
let string = "? ' a l t . b aU
m u . z ' i: k . b r a n . C @
r ' Y k . b @ . ts y: . k l I C";
let substitution = "\\1 . p";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}