import re
regex = re.compile(r"([tk]) . b", flags=re.MULTILINE)
test_str = ("? ' a l t . b aU\n"
"m u . z ' i: k . b r a n . C @\n"
"r ' Y k . b @ . ts y: . k l I C")
subst = "\\1 . p"
result = regex.sub(subst, test_str)
if result:
print(result)