using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|\s)[а-я]{1,2}(\s|$)([а-я]{1,2}(\s|$)){0,4}";
string input = @"и слова на ветер и не более да";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}